Resend my activation email : Register : Log in 
BCF: Bike Chat Forums


honda xr 125 l indicators stopped working!

Reply to topic
Bike Chat Forums Index -> The Workshop
View previous topic : View next topic  
Author Message

lyndonroberts...
Derestricted Danger



Joined: 10 Oct 2011
Karma :

PostPosted: 17:33 - 10 Oct 2011    Post subject: honda xr 125 l indicators stopped working! Reply with quote

hey guys first post here

i went to work this morning with my indicators working no problems, went to start my bike earlier and went to indicator out of where i work and nothing! no signal on the display in front of me to show the indicators are on and none of the bulbs illuminate.

y first protocol was to check if the fuse had blown. it was visually fine but i thought i better check by replacing with a new one. no luck

am abit stuck where to go from here. could it be a problem with the switch itself? or possibly the bulb on the display not lighting up? would this stop my indicators coming on?
 Back to top
View user's profile Send private message You must be logged in to rate posts

Dr. Quack
Brolly Dolly



Joined: 17 Mar 2011
Karma :

PostPosted: 17:48 - 10 Oct 2011    Post subject: Reply with quote

All this rain may have something to do with it, but I would geuss at a new flasher unit needed.

3/4 of the way down here, or better still call your local Honda dealer for a new one.
http://www.bitzforbikes.co.uk/Honda/XR_125/L3_-_L8_03_-_08
____________________
https://www.youtube.com/watch?v=UlWr_aZkUdQ
https://www.youtube.com/watch?v=atrv46i9eAE
 Back to top
View user's profile Send private message You must be logged in to rate posts

lyndonroberts...
Derestricted Danger



Joined: 10 Oct 2011
Karma :

PostPosted: 17:56 - 10 Oct 2011    Post subject: Reply with quote

the indicators just randomly came on :S like u mentioned could be abit of damp however i have had to slide the button 2/3 times to the right to indicate right if that makes sense. rather than the usual once.
 Back to top
View user's profile Send private message You must be logged in to rate posts

Dr. Quack
Brolly Dolly



Joined: 17 Mar 2011
Karma :

PostPosted: 20:26 - 10 Oct 2011    Post subject: Reply with quote

Yeah the flasher relay is on it's way out.
Sometimes they stay on as one constant light, and other times they flash really quick.
____________________
https://www.youtube.com/watch?v=UlWr_aZkUdQ
https://www.youtube.com/watch?v=atrv46i9eAE
 Back to top
View user's profile Send private message You must be logged in to rate posts

donniemateno
Spanner Monkey



Joined: 01 May 2011
Karma :

PostPosted: 06:57 - 11 Oct 2011    Post subject: Reply with quote

any idea where it may be located? manual with the bike is no help and i dont no if you know but from my own research theirs no sort of haynes manual on this bike which is shit! there is on the old models but not the 00's reg's.
 Back to top
View user's profile Send private message Send e-mail You must be logged in to rate posts

Dr. Quack
Brolly Dolly



Joined: 17 Mar 2011
Karma :

PostPosted: 09:04 - 11 Oct 2011    Post subject: Reply with quote

I'm not to sure where is is located, but it's usually a small black box cliped to the frame somewhere.
There's a PDF manual here, download as free user, enter the code and download.
http://4megaupload.com/download/honda-xl-xr-tlr125-200-200-r-79-pdf-9307924.html
____________________
https://www.youtube.com/watch?v=UlWr_aZkUdQ
https://www.youtube.com/watch?v=atrv46i9eAE
 Back to top
View user's profile Send private message You must be logged in to rate posts

Paddy.
Red Rocket



Joined: 14 Feb 2008
Karma :

PostPosted: 10:06 - 11 Oct 2011    Post subject: Reply with quote

I would look towards the switch personally.

When my relay went the dash light came on solid as did the indi's

Try the relay as its pretty cheap to find a generic one but you could have some worn area in the actual switch or just water... spray the switch with some WD40.
____________________
Current ride : Triumph Street Triple '09 - Suzuki SV650 track bike | Current car : Honda Accord '99

My biking history so far
 Back to top
View user's profile Send private message Send e-mail Visit poster's website You must be logged in to rate posts

serlant
Brolly Dolly



Joined: 06 Jul 2009
Karma :

PostPosted: 11:39 - 11 Oct 2011    Post subject: Reply with quote

What paddy said, i've had this on my VTR1000 and my XJ600, corrosion on the contact in the switch, hence switching it 2 or 3 times scratched some off? i'd take the switch apart and give the contact a clean i used some wet and dry.
____________________
1998 VTR1000, 1990 XJ600, 1996 KH125
 Back to top
View user's profile Send private message You must be logged in to rate posts
Old Thread Alert!

The last post was made 2 years, 323 days ago. Instead of replying here, would creating a new thread be more useful?
Display posts from previous:   

Post new topic   Reply to topic    Bike Chat Forums Index -> The Workshop All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum

Read the Terms of Use! - Powered by phpBB © phpBB Group
 

Debug Mode: ON - Server: peanuts (www) - Page Generation Time: 2.91 Sec - Server Load: 0.44 - MySQL Queries: 16 - CDN Objects: 36 - Page Size: 59.42 Kb